const regex = /^(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?)(?:,(?i:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d),(?:25[0-5]|2[0-4]\d|1\d\d|\d\d|\d))?))*?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d),(?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d))?)(?:,(?i:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d|any|tcp|udp|icmpv[46](?:[:](?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d),(?:25[0-5]|2[0-4]\\d|1\\d\\d|\\d\\d|\\d))?))*?$', '')
const str = `icmpV4:150,145,72`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}