package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?:(\d+)\.\s)? ( [^][]*+ (?:(?R) [^][]*)*+ ) ]`)
var str = `Lorem ipsum [1. dolor sit amet, [consectetuer adipiscing] elit.]. Aenean commodo ligula eget dolor.[2. Dolor, [consectetuer adipiscing] elit.] Aenean massa[3. Lorem ipsum] dolor.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}