const regex = /\[(?:(\d+)\.\s)? ( [^][]*+ (?:(?R) [^][]*)*+ ) ]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(?:(\\d+)\\.\\s)? ( [^][]*+ (?:(?R) [^][]*)*+ ) ]', 'g')
const str = `Lorem ipsum [1. dolor sit amet, [consectetuer adipiscing] elit.]. Aenean commodo ligula eget dolor.[2. Dolor, [consectetuer adipiscing] elit.] Aenean massa[3. Lorem ipsum] dolor.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}