package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b1?[0-8]?\d?\d\b`)
var str = `1900
1800
1799
2900
1801-1899`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}