$re = '/\b1?[0-8]?\d?\d\b/m';
$str = '1900
1800
1799
2900
1801-1899';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);