$re = '/[^\/]*/m';
$str = '3682/miniperfume-candy.jpg
3681/miniperfume-candy.jpg
4252/parfem-acqua-woman.jpg
4253/parfem-acqua-woman.jpg
3658/miniperfume-acqua-woman.jpg
3659/miniperfume-acqua-woman.jpg
3798/50ml-adriana.jpg
2103/miniparfemy-adriana.jpg
2104/miniparfemy-adriana.jpg
4254/parfem-adriana.jpg
4255/parfem-adriana.jpg
3800/50ml-adriana-rose.jpg
3801/50ml-adriana-rose.jpg
4256/adriana-rose.jpg
4258/adriana-rose.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);