import re
regex = re.compile(r"[^\/]*", flags=re.MULTILINE)
test_str = ("3682/miniperfume-candy.jpg\n"
"3681/miniperfume-candy.jpg\n"
"4252/parfem-acqua-woman.jpg\n"
"4253/parfem-acqua-woman.jpg\n"
"3658/miniperfume-acqua-woman.jpg\n"
"3659/miniperfume-acqua-woman.jpg\n"
"3798/50ml-adriana.jpg\n"
"2103/miniparfemy-adriana.jpg\n"
"2104/miniparfemy-adriana.jpg\n"
"4254/parfem-adriana.jpg\n"
"4255/parfem-adriana.jpg\n"
"3800/50ml-adriana-rose.jpg\n"
"3801/50ml-adriana-rose.jpg\n"
"4256/adriana-rose.jpg\n"
"4258/adriana-rose.jpg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")