const regex = /ERROR[\S\s]*?(?=\s+INFO|DEBUG|WARN)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ERROR[\\S\\s]*?(?=\\s+INFO|DEBUG|WARN)', 'g')
const str = `ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler\`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
DEBUG 2017/12/12 00:11:35.300 Process entered blah blah bla
WARN 2017/12/12 00:11:37.300 Possible problem with some process
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler\`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
WARN 2017/12/12 00:11:37.300 Possible problem with some process
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler\`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
TEST 2017/12/12 00:11:35.300 Process entered blah blah bla
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler\`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
INFO 2017/12/12 00:11:35.300 Process entered blah blah bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}