$re = '/ERROR[\S\s]*?(?=\s+INFO|DEBUG|WARN)/';
$str = 'ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
DEBUG 2017/12/12 00:11:35.300 Process entered blah blah bla
WARN 2017/12/12 00:11:37.300 Possible problem with some process
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
WARN 2017/12/12 00:11:37.300 Possible problem with some process
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
TEST 2017/12/12 00:11:35.300 Process entered blah blah bla
ERROR 2017/12/12 00:11:34.352 Error: {0} System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> OutboundServiceSoftFailureException: Failure executing request against aggregation service: Object reference not set to an instance of an object. at ProxyAggregationService.Execute[T](ILog log, Request request) at ResetChangeRequestForMAF(String mafGuid, String senderCode) at HandleImpl(CleanupWorkbookRequest request) at UnitRequestHandler`1.Handle(TRequest request) at ExecuteInternal[TRequest,TResponse](TRequest request) --- End of inner exception stack trace --- at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at ExecuteUnknown(Object request) at InvokeMethodOnTarget() at CProceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation) at AbstractInvocation.Proceed() at Intercept(IInvocation invocation)
INFO 2017/12/12 00:11:35.300 Process entered blah blah bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);