import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)(?=On\\s+\\d{2}\\-\\d+\\-\\d+|\\#{2}\\-.*?\\-\\#{2})";
final String string = "Second reply. #2\n\n"
+ "Met vriendelijke groet,\n"
+ "{sender name}\n\n"
+ "{company details}\n\n"
+ "On 25-02-15 14:38, {email name} wrote:\n"
+ "> [Ticket ID: 54e70396110971424425] Re: 54e70396110,678567.971424425\n"
+ ">\n"
+ "> ##- Please type your reply above this line -##\n"
+ ">\n"
+ "> Your request (54e70396110971424425) has been deemed solved. To reopen, \n"
+ "> please reply to this email or login on {name} to reply.\n"
+ ">\n"
+ "> ------------------------------------------------------------------------\n"
+ ">\n"
+ "> Feb 25, 14:38\n"
+ ">\n"
+ "> Dear Test user,\n"
+ ">\n"
+ "> First reply. #1\n"
+ ">\n"
+ ">\n"
+ "> {name}\n"
+ "> {company details}\n"
+ ">";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}