# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?)(?=On\s+\d{2}\-\d+\-\d+|\#{2}\-.*?\-\#{2})"
test_str = ("Second reply. #2\n\n"
"Met vriendelijke groet,\n"
"{sender name}\n\n"
"{company details}\n\n"
"On 25-02-15 14:38, {email name} wrote:\n"
"> [Ticket ID: 54e70396110971424425] Re: 54e70396110,678567.971424425\n"
">\n"
"> ##- Please type your reply above this line -##\n"
">\n"
"> Your request (54e70396110971424425) has been deemed solved. To reopen, \n"
"> please reply to this email or login on {name} to reply.\n"
">\n"
"> ------------------------------------------------------------------------\n"
">\n"
"> Feb 25, 14:38\n"
">\n"
"> Dear Test user,\n"
">\n"
"> First reply. #1\n"
">\n"
">\n"
"> {name}\n"
"> {company details}\n"
">")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.