package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+@\S+`)
var str = `admin@gmail.com
admin+hello@gmail.com
admin@super.travel
admin@gmail.co.uk
admin@mail.ru
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}