re = /\S+@\S+/m
str = 'admin@gmail.com
admin+hello@gmail.com
admin@super.travel
admin@gmail.co.uk
admin@mail.ru
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end