using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+?class=""([^""]+)"".+id=""([^""]+)"".+?$";
string input = @"<td class=""check ABCD"" rowspan=""2""><center><div class=""checkbox {{#if checked}}select{{else}}deselect{{/if}}"" id=""{{id}}"" {{data ""tool""}
<td class=""check"" rowspan=""2""><center><div class=""checkbox {{#if checked}}select{{else}}deselect{{/if}}"" id=""{{id}}"" {{data ""tool""}}>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}