re = /^.+?class="([^"]+)".+id="([^"]+)".+?$/m
str = '<td class="check ABCD" rowspan="2"><center><div class="checkbox {{#if checked}}select{{else}}deselect{{/if}}" id="{{id}}" {{data "tool"}
<td class="check" rowspan="2"><center><div class="checkbox {{#if checked}}select{{else}}deselect{{/if}}" id="{{id}}" {{data "tool"}}>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end