$re = '/^(\+|-|\*| )(?P<remote>(?:[0-9]{1,3}\.){3}[0-9]{1,3})\s+(?P<refid>(?:(?:[0-9]{1,3}\.){3}[0-9]{1,3})|(.LOCL.|.INIT.))\s+(?P<st>\d+)\s+(?P<t>\w)\s+(?P<when>\d+|-)\s+(?P<poll>\d+)\s+(?P<reach>\d+)\s+(?P<delay>-?(?:\d+).?\d+)\s+(?P<offset>-?(?:\d+).?\d+)\s+(?P<jitter>-?(?:\d+).?\d+)/m';
$str = '+172.18.251.100 129.6.15.29 2 u 715 1024 377 0.135 1.820 2.397
-172.28.251.100 132.163.97.6 2 u 898 1024 377 0.193 -1.765 1.040
+172.18.251.101 129.6.15.30 2 u 673 1024 377 0.076 -0.358 0.452
*172.28.251.101 129.6.15.30 2 u 172 1024 377 0.075 0.690 0.165
127.127.1.0 .LOCL. 10 l 1251 64 0 0.000 0.000 0.000
172.30.251.100 .INIT. 16 u - 1024 0 0.000 0.000 0.000
172.30.251.101 .INIT. 16 u - 1024 0 0.000 0.000 0.000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);