#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(===.*===[\s\S]*?)(?====|$)"
Local $sString = "=== Jun 11 14:05:39 - Person Details ===" & @CRLF & _
"" & @CRLF & _
"Person Name = "Hurlman"" & @CRLF & _
"" & @CRLF & _
"Person Address = "2nd Street Benjamin Blvd NJ"" & @CRLF & _
"" & @CRLF & _
"Persion Age = 25" & @CRLF & _
"" & @CRLF & _
"=== Jun 11 14:05:39 - Person Details ===" & @CRLF & _
"" & @CRLF & _
"Person Name = "Greg"" & @CRLF & _
"" & @CRLF & _
"Person Address = "3rd Street Benjamin Blvd NJ"" & @CRLF & _
"" & @CRLF & _
"Persion Age = 26" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"=== Jun 11 14:05:42 - Person Details ===" & @CRLF & _
"" & @CRLF & _
"Person Name = "Michel"" & @CRLF & _
"" & @CRLF & _
"Person Address = "4th Street Benjamin Blvd NJ"" & @CRLF & _
"" & @CRLF & _
"Persion Age = 27"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")