import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(===.*===[\\s\\S]*?)(?====|$)";
final String string = "=== Jun 11 14:05:39 - Person Details ===\n\n"
+ "Person Name = \"Hurlman\"\n\n"
+ "Person Address = \"2nd Street Benjamin Blvd NJ\"\n\n"
+ "Persion Age = 25\n\n"
+ "=== Jun 11 14:05:39 - Person Details ===\n\n"
+ "Person Name = \"Greg\"\n\n"
+ "Person Address = \"3rd Street Benjamin Blvd NJ\"\n\n"
+ "Persion Age = 26\n\n\n"
+ "=== Jun 11 14:05:42 - Person Details ===\n\n"
+ "Person Name = \"Michel\"\n\n"
+ "Person Address = \"4th Street Benjamin Blvd NJ\"\n\n"
+ "Persion Age = 27";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}