package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^,"']+|"[^"]*"|'[^']*')+)`)
var str = `abcd, efgh, ij"k,l", mnop, 'q,rs't`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}