re = /((?:[^,"']+|"[^"]*"|'[^']*')+)/
str = 'abcd, efgh, ij"k,l", mnop, \'q,rs\'t'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end