package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\()(?(1)\)|)`)
var str = `empty line
Line with correct ( idk how they spelled)
Line to be cleared of )))
Mixed (line))()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}