$re = '/(\()(?(1)\)|)/m';
$str = 'empty line
Line with correct ( idk how they spelled)
Line to be cleared of )))
Mixed (line))()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);