const regex = /http:\/\/(.*?)\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/(.*?)\\\/', '')
const str = `http://10.22.14.152/something/api`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}