$re = '/http:\/\/(.*?)\//';
$str = 'http://10.22.14.152/something/api';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);