package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bthis\b|(\w+)`)
var str = `capture each word except this with_this_in_it
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}