$re = '/\bthis\b|(\w+)/m';
$str = 'capture each word except this with_this_in_it
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);