re = /@\[([a-z\d]+):\+([^\[\]]+)\]/m
str = 'some text @[14cd3:+Seldum Kype] things are going good for @[7f8ef3:+Kerry Williams] so its ok'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end