package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/support\.microsoft\.com\/\?kbid=`)
var str = `http://support.microsoft.com/?kbid=3046017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}