$re = '/http:\/\/support\.microsoft\.com\/\?kbid=/';
$str = 'http://support.microsoft.com/?kbid=3046017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);