re = /^https:\/\/([www]|[*]\.)?[-a-zA-Z0-9@:%._+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_+.~#?&\/\/=].*)?/mi
str = 'https://google.com
https://www.google.com
https://www.google.com/*
https://*.google.com/
https://*.google.com/asdasdas/*
https://*.regex101.com/asdasdas/*
HTTPS://Lorem.Ipsum.dolor.sit.com/amet/*/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end