import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":.*(Atlas.[^/]*)[/][^:]*:[^:]*:[^:]*:[^:]*:client_process:severity";
final String string = ":soc.Atlas.Demback/P0:Atlas:Demback/P0::client_process:severity | il=5 min=0 avg=0 max=0\n"
+ ":soc.Atlas.Demback/P1:Atlas:Demback/P1::client_process:severity | il=5 min=0 avg=0 max=0\n"
+ ":soc.Atlas._qxm_mdsp:Atlas:qxm_mdsp::client_plug:pendingVolume | il=3 bwd=2.60748e+09 avgVol=353.612 maxVol=1088 minLat=6.824e-08 avgLat=1.35614e-07 maxLat=2.1676e-07 emptyRatio=0.00813047 fullRatio=0 unit=B\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}