$re = '/:.*(Atlas.[^/]*)[/][^:]*:[^:]*:[^:]*:[^:]*:client_process:severity/';
$str = ':soc.Atlas.Demback/P0:Atlas:Demback/P0::client_process:severity | il=5 min=0 avg=0 max=0
:soc.Atlas.Demback/P1:Atlas:Demback/P1::client_process:severity | il=5 min=0 avg=0 max=0
:soc.Atlas._qxm_mdsp:Atlas:qxm_mdsp::client_plug:pendingVolume | il=3 bwd=2.60748e+09 avgVol=353.612 maxVol=1088 minLat=6.824e-08 avgLat=1.35614e-07 maxLat=2.1676e-07 emptyRatio=0.00813047 fullRatio=0 unit=B
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);