import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Subject\\s*:\\s*(?P<subject>.+)";
final String string = "From 1488780641874111180@xxx Mon Dec 29 12:11:00 2014\n"
+ "X-GM-THRID: 1488780145305309925\n"
+ "X-Gmail-Labels: Sent,Important\n"
+ "MIME-Version: 1.0\n"
+ "Received: by 10.52.29.70 with HTTP; Sun, 28 Dec 2014 16:11:00 -0800 (PST)\n"
+ "X-Originating-IP: [82.13.144.221]\n"
+ "In-Reply-To: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>\n"
+ "References: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>\n"
+ "Date: Mon, 29 Dec 2014 00:11:00 +0000\n"
+ "Delivered-To: hello@domain.co\n"
+ "Message-ID: <CAN8wjQQWm33RS-hDdE1k3c6CMOge9-eq=3GrcNssV8gPYi+osA@mail.gmail.com>\n"
+ "Subject: Re:<<<regading account : creation>>>\n"
+ "From: DG <hello@domain.co>\n"
+ "To: info@otherdomain.us\n"
+ "Content-Type: multipart/alternative; boundary=001a11c2183a9b3b4e050b4fb549\n"
+ "--001a11c2183a9b3b4e050b4fb549\n"
+ "Content-Type: text/plain; charset=UTF-8\n"
+ "Hey Chris,\n"
+ "Is that price for the pass with tax?\n"
+ "Also do you have any recommendations for good rental places in town?\n"
+ "Cheers,\n"
+ "-dave";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}