# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Subject\s*:\s*(?P<subject>.+)"
test_str = ("From 1488780641874111180@xxx Mon Dec 29 12:11:00 2014\n"
"X-GM-THRID: 1488780145305309925\n"
"X-Gmail-Labels: Sent,Important\n"
"MIME-Version: 1.0\n"
"Received: by 10.52.29.70 with HTTP; Sun, 28 Dec 2014 16:11:00 -0800 (PST)\n"
"X-Originating-IP: [82.13.144.221]\n"
"In-Reply-To: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>\n"
"References: <01ff42fddfded95cfa8b14fa5559b0fb.squirrel@webmail04.register.com>\n"
"Date: Mon, 29 Dec 2014 00:11:00 +0000\n"
"Delivered-To: hello@domain.co\n"
"Message-ID: <CAN8wjQQWm33RS-hDdE1k3c6CMOge9-eq=3GrcNssV8gPYi+osA@mail.gmail.com>\n"
"Subject: Re:<<<regading account : creation>>>\n"
"From: DG <hello@domain.co>\n"
"To: info@otherdomain.us\n"
"Content-Type: multipart/alternative; boundary=001a11c2183a9b3b4e050b4fb549\n"
"--001a11c2183a9b3b4e050b4fb549\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Hey Chris,\n"
"Is that price for the pass with tax?\n"
"Also do you have any recommendations for good rental places in town?\n"
"Cheers,\n"
"-dave")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.