const regex = /((?:(?(?=(e.g.|z.b.|Figs?\.|\d+\.\d))\2|[^.!?])+[.!?]))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(?(?=(e.g.|z.b.|Figs?\\.|\\d+\\.\\d))\\2|[^.!?])+[.!?]))', 'gi')
const str = `Test 10. Testing. Testing. Fig. 20. The decimal 20.3 should 20 still be sentence.Ok now. try 2.3. Explained reference to Figs. 2 and 3. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}