use strict;
my $str = 'abcbbabbabcd';
my $regex = qr/a(?:(?!a).)*c/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";