$re = '/[^() ]*(\((?:[^()]|(?1))*\))/';
$str = 'This is a test to see if something(try_(this(once))) works';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);