re = /[^() ]*(\((?:[^()]|(?1))*\))/
str = 'This is a test to see if something(try_(this(once))) works'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end