use strict;
my $str = 'ThisIsAn ExampleString';
my $regex = qr/(?<=[a-z])(?=[A-Z])/p;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";