$re = '/(?<=[a-z])(?=[A-Z])/';
$str = 'ThisIsAn ExampleString';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;