package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?://.+?/(?P<company>[^/]+)/`)
var str = `http://myipaddress:myport/mycompanyname/morethings?lovelyparameter`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}