$re = '~https?://.+?/(?P<company>[^/]+)/~';
$str = 'http://myipaddress:myport/mycompanyname/morethings?lovelyparameter';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);