use strict;
my $str = '15. April 2003';
my $regex = qr/(\d+)\. (\w+) (\d+)/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";