$re = '/(\d+)\. (\w+) (\d+)/i';
$str = '15. April 2003';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;