#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d)\d(?=[a-zA-Z]|$)"
Local $sString = "1" & @CRLF & _
"2a" & @CRLF & _
"12" & @CRLF & _
"23a" & @CRLF & _
"3a" & @CRLF & _
"4A" & @CRLF & _
"5z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")