$re = '/(?<!\d)\d(?=[a-zA-Z]|$)/m';
$str = '1
2a
12
23a
3a
4A
5z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);