const regex = /^(.*?)[ ._-]*(?:s\w*\s*\d+)?(?:e\d\d(?:-\d\d)?)?[\s.]*\w*?\.torrent(?:[\s\S]*\1.*$)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)[ ._-]*(?:s\\w*\\s*\\d+)?(?:e\\d\\d(?:-\\d\\d)?)?[\\s.]*\\w*?\\.torrent(?:[\\s\\S]*\\1.*$)*$', 'gmi')
const str = `Veep - Season 1 BDMux.torrent
Vegas S01e01-21.torrent
Velvet S01e13.torrent
Velvet.e10.torrent
Velvet_e01.torrent
Veronica Mars s01.torrent
Vicious S01e01-06.torrent
Victor Ros S01e01-06.torrent
Video.Game.High.School.S01e01-09.XviD.torrent
Vikings - Season 1 EXT.torrent
Vikings_S04e04.avi.torrent
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);