# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*?)[ ._-]*(?:s\w*\s*\d+)?(?:e\d\d(?:-\d\d)?)?[\s.]*\w*?\.torrent(?:[\s\S]*\1.*$)*$"
test_str = ("Veep - Season 1 BDMux.torrent\n"
"Vegas S01e01-21.torrent\n"
"Velvet S01e13.torrent\n"
"Velvet.e10.torrent\n"
"Velvet_e01.torrent\n"
"Veronica Mars s01.torrent\n"
"Vicious S01e01-06.torrent\n"
"Victor Ros S01e01-06.torrent\n"
"Video.Game.High.School.S01e01-09.XviD.torrent\n"
"Vikings - Season 1 EXT.torrent\n"
"Vikings_S04e04.avi.torrent\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.