package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[ -@[-`{-~]+`)
var str = `[MV] SUNMI(선미) _ 누아르(Noir)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}