$re = '/[ -@[-`{-~]+/m';
$str = '[MV] SUNMI(선미) _ 누아르(Noir)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);